PID

iVillage Member
Registered: 08-21-2006
PID
3
Mon, 01-03-2011 - 7:28pm

Has anyone had PID?

I had a miscarriage at about 8 weeks in mid-November. I did not have to have a D&C but I did have an in-office procedure just to remove a fairly large clot of tissue. An ultrasound showed I had passed most everything and I had a course of antibiotics as a preventive measure. Anyway, I've had persistent low back pain since then. I didn't think anything of it, just thought I pulled something unrelated and then lifting my 3 and a half year old just kept it from feeling better.

I got my period in mid-December right when I was thinking/hoping I would so I figured everything was AOK but I've had some mid-cycle spotting. Like, a day a week ago and then a little yesterday afternoon. And I don't think it's related to ovulation or anything like that. I don't know if I'm being crazy and just assuming something is wrong when really my body is just still getting back to normal.

I haven't had any fever. I do have some pelvic pain today but it's not severe or anything. I wonder if I would have even noticed if I weren't "looking for it" KWIM? Anyway, I wouldn't be expecting my period until about the 14th or later so it's also to early for implantation spotting or anything like that.

Who knows.

Sig for PJs

Thanks to Melinda for the cutie-p
Community Leader
Registered: 10-08-2002
In reply to: suze2007
Wed, 01-05-2011 - 5:06pm

Sorry you had to go through all that.

Photobucket

iVillage Member
Registered: 12-08-2010
In reply to: suze2007
Wed, 01-05-2011 - 9:47am

Have you had any pain with intercourse?

Don't sweat the small stuff!
iVillage Member
Registered: 08-07-2007
In reply to: suze2007
Tue, 01-04-2011 - 4:43pm
Since you don't believe the bleeding/spotting is related to ovulation, you might want to give your doctor a call just to be sure.