Latest Update - 11/08/12

Avatar for cdjessica
iVillage Member
Registered: 07-13-2011
Latest Update - 11/08/12
38
Thu, 11-08-2012 - 1:05pm

Hi, everyone.

I'm happy to report that after the office was without power all last week due to the hurricane, the whole team is back in the office as of yesterday! Monday's commute was impossible for some since we only had limited trains into and out of the city, election day was Tuesday, but by Wednesday we were reunited (despite the fact that some people are still dealing with flooded homes or power outages).

As of Tuesday, I'm in a daily meeting with the President of iVillage and the CTO regarding the status of our message board fixes. Every day, we discuss what the priority list is, what progress is being made, what's holding us back, and what resources are needed to cross items off the list.

Right now, the #1 priority (for all of iVillage, not just for the message boards project) is fixing the error pages we're seeing again on the boards. I expect many of these to clear up tomorrow, if not later today. 

They have also released the fix for Viewing Replies. I've been told that many people can now see replies on the site, and on their ipads and phones. If you can't, please PM me or email us, so we can continue troubleshooting! If you could let me know the URL where you can't see replies, what device you're using, and what browser you're in, that would be very helpful.

After the error messages are resolved, the next item on the priority list is fixing the ability to reply. Obviously some of you can reply, but some of you can't...we just need to figure out why that is. 

In the meantime, there are other message board fixes that are being worked on:

>> Fixing the "this email is already in use" error you get when trying to edit your preferences. This has now turned into a mini-project. We believe that if you're getting this error, you probably have a duplicate account in your history with iVillage (same email / various usernames attached to it). Essentially, when you try to change your account settings, our system doesn't know which of your usernames you are trying to affect. I'm waiting on a list of accounts that our system says, "this is a duplicate." 

>> Getting the private team boards (boards only used by CLs and Mods) back online. Also a mini-project, but it looks like we're close!

>> Removing the character limit from the signature field. This impacts more than just the signature field, apparently. I've let the team know that I definitely want the character limit raised, and now I'm just waiting on them to confirm that it's a safe change to make to our system.

>> We got the final version of Lithium's iVillage data, and are (still...) currently importing it into our database. It's so gigantic, it takes a few days! Once it's in, we can begin the process of restoring missing threads, missing boards, your images, etc.

Of course, there are more items on my post-launch, fix-this-immediately list based on your feedback. But this week, the above items have been the focus, and will continue to be until they're fixed and we can move on to the next batch.

I know everyone's tired of hearing "thanks for your patience" and "we're working on it"...I guess I'm running out of different ways to say it, too! But the truth is, we're all still working very hard at debugging these problems, creating fixes for them, testing the fixes, and pushing them live.

Of equal importance is the fact our boards are the top priority for iVillage right now. Work is not slowing down, we're just in a position where we need to give the tech team the time they need. Believe me, I'd like to move my computer back to the tech cave so I can hang on every word they say...but that would be annoying, I guess. :)

As soon as I have something else to report, I will. Thanks for your patience (I really mean that!),

Jess

...keep going!

Avatar for cdjessica
iVillage Member
Registered: 07-13-2011
Mon, 11-12-2012 - 2:50pm

islaywhisky wrote:
<p><span style="font-family:verdana,geneva">Jessica,</span></p><p><span style="font-family:verdana,geneva">In the interests of everyone - including you and your colleagues who are working so hard to get iVillage up and running smoothly again - could you give us a speculative, time-frame before we are in that happy state once again? Should we be thinking in weeks, months or even a year?</span></p><p><span style="font-family:verdana,geneva">Christopher</span></p>

Thanks, Christopher.

Right now, there are 3 buckets of requests I've given the tech team:

Post-launch fixes: Essentially, these are the items on the Top 10 list I created immediately after launch plus any outages / error pages that have cropped up since then. I think it's safe to put "post launch fixes" in the "weeks" column. Thankfully, these message boards fixes are the top priority among all iVillage projects and the entire team is assigned to work on them. At this point, they're all being worked on concurrently. 

Known Bugs: After the post-launch fixes are complete, I'll start prioritizing a few bugs a week for them to fix. This is a long list, so it could take months.

Phase 2 improvements & add-ons: This list includes things like adding back in Tagging or creating a smarter Archiving experience...larger projects that will take weeks of time, each. Also in this bucket -- building features that we didn't launch with (Marking things as read or unread, for example) because our platform doesn't support it.

After post-launch fixes are complete, the plan is to tackle one Phase 2 project while also addressing a few from the Known Bugs column each week.

I wish I had more concrete estimates -- I'll share them when I do! Sometimes, I don't get solid time estimates until the team is close to finding a fix for the item they're working on. 

:)

...keep going!

Avatar for cdjessica
iVillage Member
Registered: 07-13-2011
Mon, 11-12-2012 - 2:24pm

brendaluvschance wrote:
<p>Thanks for all your hard work!!!</p>

Thanks so much! :)

(Nice to hear!)

...keep going!

Avatar for cdjessica
iVillage Member
Registered: 07-13-2011
Mon, 11-12-2012 - 2:23pm

marketingvirgo wrote:
Jess - If this goes through, Quick Reply worked! Just wondered what the status was on browsers other than IE? At home I am on Mozilla or Google Chrome and those just are not working. Also, the "next discussion" tabs are still missing. Would love those back too. -Marie

Hi, there --

If you can't reply, try refreshing the page. (Happened to me this morning  -- Quick Reply just disappeared until I hit F5 to reload the page.)

I've reported a bug where after logging in, the system is taking you back to the message boards faster than it can recognize that you're logged in. So if you try to reply, it will give you an error message. 

As for the "previous / next" discussion links, we have to build those back in, anew. It was one of the details that didn't come with the message boards package we're using.

Thanks!

...keep going!

Avatar for cdjessica
iVillage Member
Registered: 07-13-2011
Mon, 11-12-2012 - 2:07pm

elc11 wrote:
<p>Jess, I also used to have 2 names associated with my email address: elc11 and cl-elc11. I didn't do anything to deactivate or disable the cl name, it just disappeared with the Lithium launch 2 years ago. Just wondering if the system could be seeing those old cl- names and that's causing confusion? </p>

Thanks, ELC. I think that's it in a nutshell. Although, some people report never having more than one username, and they're getting the same error. Sounds like we're dealing with more than 1 bug in here. 

...keep going!

iVillage Member
Registered: 08-25-2005
Sun, 11-11-2012 - 11:19am

I'm getting the "this email is already used" BS. Issue here, I've only EVER had one screen name; except when I was a CM-worst year of my LIFE, but that was connected to my CM email not my normal one. AND the other issue, it wouldn't even be a problem with the email I use now because I only recently changed it on my account. I used to use my Yahoo address for everything and I lost access to it so I switched to my Gmail accout, which has never been connected to iVillage, so it really shouldn't be an issue at all for me.

So what gives? If I can't change my signature can you at least remove the one that is currently showing up? I'm not too jazzed about having pictures of my kids plastered all over this place because you all couldn't test your "upgrade" before rolling it out.

Photobucket
iVillage Member
Registered: 10-25-2006
Fri, 11-09-2012 - 5:09pm

deleted cuz posted 2X --- must have hit 'post' button twice

-----------------------------------------------
http://www.pnhp.org/news/2009/october/meet_the_new_health_.php

http://www.youtube.com/watch?v=DQTBYQlQ7yM

iVillage Member
Registered: 10-25-2006
Fri, 11-09-2012 - 5:06pm

Anyone else get the "you are not allowed to post comments" message after hitting reply and signing in?  I always have to sign in 2-3X before I can comment......weird.  This time I didn't get the message, but neither was I signed in on the first try.

Also, why is the text box for entering our replies so small now?  Only 5 lines fit without having to scroll up and down. Kind of annoying......

Thanks for your work in fixing these inconveniences.

-----------------------------------------------
http://www.pnhp.org/news/2009/october/meet_the_new_health_.php

http://www.youtube.com/watch?v=DQTBYQlQ7yM

iVillage Member
Registered: 07-27-2001
Fri, 11-09-2012 - 10:34am
Thanks for the hard work...any news on how it's coming in regards to after posting it taking you to the end of the thread vs. where you left off?! I've seen tons of other issued fixed and/or addressed but never this issue. ??? It's quite frustrating when you're in a long thread & it pops you to the end of the thread after posting vs. back to where you were.
Photobucket
Avatar for islaywhisky
iVillage Member
Registered: 01-06-2002
Thu, 11-08-2012 - 8:51pm

Jessica,

In the interests of everyone - including you and your colleagues who are working so hard to get iVillage up and running smoothly again - could you give us a speculative, time-frame before we are in that happy state once again? Should we be thinking in weeks, months or even a year?

Christopher

"Education is the discovery of our own ignorance." Will Durant


"Almost any manmade phenomenon i

Community Leader
Registered: 07-16-2001
Thu, 11-08-2012 - 6:32pm
I also have only had one name, other than my cl-shywon name associated with my email address. I do think pre-lithium data is mixed in there somewhere because my join date is now correct and it was wrong under lithium. I'd really like to see a button in the mobile version that takes me back to the board. It seems like a simple thing that should be there, but isn't.