No letdown?

iVillage Member
Registered: 02-04-2012
No letdown?
4
Sat, 02-04-2012 - 11:56am
I've been EPing for three and a half months now. LO is four months old. All has been fine except I find it is taking longer and longer to completely drain and my supply is dropping slightly (although that is ok since I was overproducing for a while and my freezer is full). I don't seem to be getting a letdown anymore - I never gush into the horns, just drip drip for 45 minutes or longer. I've tried heat and massage with no luck. Could this be a pump issue? Is it possible to never get a real letdown? I seem to have plenty of supply and was even engorged this morning but still just drip drip. There aren't really enough hours in the day if each pump is going to take me nearly an hour! Any advice is appreciated!
iVillage Member
Registered: 05-25-2011
In reply to: alf2012
Mon, 02-06-2012 - 12:23pm

Also, if you haven't replaced your membranes yet, it's time to do that.

iVillage Member
Registered: 05-25-2011
In reply to: alf2012
Mon, 02-06-2012 - 12:22pm

I don't think this is unusual since you are past the 12 week mark.

iVillage Member
Registered: 12-23-2011
In reply to: alf2012
Sun, 02-05-2012 - 1:32am
Just thought of this - what happens if you handexpress?
iVillage Member
Registered: 12-23-2011
In reply to: alf2012
Sun, 02-05-2012 - 1:32am
One way I can tell that my pump/membranes are working is to if I see my nipple being pulled like it is supposed to when everything is working. I am not sure if it is a good judge or not but so far it has been working from me. I only have 2 months of EP experience so may be others will have more concrete answers.