Scared to death!

iVillage Member
Registered: 09-21-2011
Scared to death!
3
Wed, 09-21-2011 - 6:19pm

I've been on Ortho Lo for years. Last had sex Aug 19th. Started taking the green pills (period pills) on Sunday and have yet to start my period. It NEVER takes me this long to start. Could I be preggo?? Havent taken any antibiotics in over a year, and I take the pill regularly. What's up with this????

Community Leader
Registered: 07-07-2008
Wed, 09-21-2011 - 8:46pm

So if I'm calculating this right, you last had sex on August 19th and then you would've started the green pills the following Sunday, August 21st. Did you have a normal period in August? Do you take your pills at the same time every day? I know you said you take them regularly, I'm just asking to see if you actually take them the same time every day because sometimes that can make a difference.

Besides your period not showing up, do you have any other signs of pregnancy?

iVillage Member
Registered: 09-21-2011
Wed, 09-21-2011 - 9:10pm

I dont seem to remember anything abnormal about my Aug period. I dont take my pill at the same time everyday, partially due to my work schedule. I usually just take it when I get up, but that time differs depending on what time I have to be at work. I did not use a condom. I may be overreacting, but this is just scaring the crap out of me because I have never missed a period before. Ever. I dont seem to have any other signs of pregnancy. Havent been sick, my breasts arent really tender... I'm so worried :(

Community Leader
Registered: 07-07-2008
Wed, 09-21-2011 - 10:44pm
How much of a difference is there in the times you get up in the morning? With not taking it at the same time every day, it is possible that there was a gap long enough for you to have ovulated. Once again, it's rare, but possible. I'd definitely test if your period doesn't show up before you start your next pack of pills!