Infection....maybe???

iVillage Member
Registered: 05-08-2009
Infection....maybe???
8
Tue, 12-13-2011 - 11:07am

I had my regular midwife appointment today, and was curious if anyone has had anything similar happen to them. I've been having sporadic symptoms of some type of infection.....(sorry TMI) super-vaginal itching for a few days, then nothing for a few days. Then other symptoms that seem like a UTI....achey feeling, strong/bad smelling urine (but sporadic, only a couple times....maybe something I ate)? The bad thing is that some of my symptoms are also regular pregnancy symptoms so I've really been going back and forth about them. At my appointment I gave a urine sample and also had a vaginal swab done. I've been treated my last few appointments for a yeast infection (because of the itching), but this time she's not seeing any yeast or even any bacterial vaginosis in the sample she took. I haven't gotten the results back from the urine yet so I'm not sure if there is something going on there.

Just curious if anything has had anything similar that was something besides a yeast infection or bacterial vaginosis. Otherwise the appointment went well, baby is moving around and I'm feeling lots of regular movement which is nice. U/S next week!

Thanks!

Lee, Mommy to DD Noelle born January 2010. BFP in February 2011, lost pregnancy at 10 weeks in April 2011. BFP in August 2011, hopeful and happy to be expecting our baby due May 9, 2012.

iVillage Member
Registered: 05-03-2007
Tue, 12-13-2011 - 5:52pm
Asparagus will make ur urine smell pretty bad.. i never get yeast infections except the begining of my pregnancy and about a week before birth.. its caused by the hormone changes.. and, not to be gross, u secret more vaginal fluid that helps to keep infection and bacteria away.. its pretty stout.. u could just be irritated by the fluid causing itching and mild disomfort.. u also could have ur baby on ur bladder.. lots of discomfort there! im sure ur fine and its nothing a dr. Cant handle.. : )
iVillage Member
Registered: 05-11-2010
Wed, 12-14-2011 - 7:57am

Lee - I'm glad that you had a culture and a urine screen; hope you find out what's up very soon.

iVillage Member
Registered: 05-08-2009
Wed, 12-14-2011 - 9:15pm

Julia - Oh my goodness!! Sounds like you have been through a lot in the past few days. I'm glad the antibiotic is kicking in! I'll be curious to hear what they find out about the bacteria.

My midwife did see some white blood cells in the swab sample she took which she said indicates an infection, but it's just not clear what it is. For now I'm taking lots of probiotics and doing an apple cider vinegar rinse vaginally

Lee, Mommy to DD Noelle born January 2010. BFP in February 2011, lost pregnancy at 10 weeks in April 2011. BFP in August 2011, hopeful and happy to be expecting our baby due May 9, 2012.

iVillage Member
Registered: 05-11-2010
Thu, 12-15-2011 - 8:17am

Thanks, Lee.

iVillage Member
Registered: 06-09-2009
Thu, 12-15-2011 - 8:32am
Holy Julia! Sounds like you have been in a lot of pain. I had a UTI infection when I was in high school and it was so painful so it moving to your kidneys I can't even imagine what the pain. Hope you continue to feel better.

Lesley
iVillage Member
Registered: 06-09-2009
Thu, 12-15-2011 - 8:35am
Lee, I have given many urine samples with white blood cells, it seems to be the norm for me, one of those medical mysteries. I take a probiotic, have been for years and am crossing my fingers it will kep me YI free my pregnancy. I also read it can help keep you negative from group B strep. I hope whatever is going on you things stay okay.

Lesley
iVillage Member
Registered: 05-08-2009
Thu, 12-15-2011 - 1:31pm

Lesley - That's really interesting about probiotics keeping you clear of group b strep. I had that with my daughter and it'd be nice to avoid it this time. Just a pain mostly....all those antibiotics and then later we had to deal with a fun case of thrush. I'm definitely going to keep it up for the whole pregnancy.

Well, I heard back from the office and there is no sign of a UTI in my urine sample. So maybe having some white blood cells is normal for me, too, who knows?? Hopefully the things they've given me to do help, we'll see when I go back in a couple weeks. At least they can't hurt! I'm just glad that I've gotten some things checked out, it gives me a little peace of mind even though they're not really sure what (if anything) is going on. I know your body just gets so whacked out with pregnancy so maybe that really is it this time.

Lee, Mommy to DD Noelle born January 2010. BFP in February 2011, lost pregnancy at 10 weeks in April 2011. BFP in August 2011, hopeful and happy to be expecting our baby due May 9, 2012.

iVillage Member
Registered: 05-11-2010
Fri, 12-16-2011 - 10:41am

That's really good news.