Anyone had a cycle like this?

iVillage Member
Registered: 03-28-2003
Anyone had a cycle like this?
2
Fri, 03-28-2003 - 4:54pm
I am on day 27. Today, after 26 days of no temp shift, my temp is up. I have what feels like O pain, too. BUT, the EWCM ended over a week ago and I've been dry since. I had a positive OPK over a weeks ago, around the same time as the EWCM. My CP has been high for a week too. Could I have delayed O this long? The twinge in my ovary area has been going on all day. What's going on? I know you all don't have a crystal ball, but maybe an educated opinion would help me.

Avatar for maciascl
iVillage Member
Registered: 03-26-2003
Fri, 03-28-2003 - 6:05pm
Could it be that when you got the + OPK & had the EWCM you o'd & wha you are feeling now is PMS cramping? How long are your cycles usually?
Photobucket - Video and Image Hosting    
iVillage Member
Registered: 03-28-2003
Fri, 03-28-2003 - 8:28pm
It doesn't feel like cramps. In fact, I don't have anything going on except sensative nipples. No bloating, no cramps, no fatigue. I'm kind of crabby, but I think it's stress. I really can't tell either way. I've been pregnant before and they all didn't start out the same way. With some I felt it from the start, others nothing for 5 or 6 weeks. Since I didn't have a thermal shift, I'm thinking no O or late O. But if it's late O, I'd have had the EWCM come back. Wouldn't I? And my CP being high puzzles me too this late in my cycle. My cycles are 28-29 days. I took an HPT this morning, a really sensative one, it was negative. I might keep testing though.