EPO and no ovulation this month?

iVillage Member
Registered: 08-19-2010
EPO and no ovulation this month?
7
Fri, 08-20-2010 - 12:23pm

Hi,
I had started taking EPO (as well as L Arginine ) this cycle and on days 12-14 I had an open cervix
and fertile mucous- thought I was set to ovulate and no temp shift has taken place at all. Np breast tenderness that I usually get around O and afterwards- nothing.

I am guessing it's the EPO- or is it because I changed time zones 3 weeks ago (going from Southern Hemisphere to Northern Hemisphere)?

44- 5 children already- TTC number 6!
iVillage Member
Registered: 06-30-2010
Fri, 08-20-2010 - 1:29pm

Hi,


Sorry I don't have an answer for you.

About me: A pixie in the city, 41, TTC#1 since May 2010, married 18 years.


Diagnosed with/surgically removed endometrioma Aug 2010. Sept IUI #1=BFN. Nov IUI #2=BFN. Uterine polyp removed Jan. 2011. Jan 2011 IVF cancelled. No response. 2nd

iVillage Member
Registered: 08-19-2010
Fri, 08-20-2010 - 2:37pm
Hi there,
Yes, I am new to the board- joined yesterday!
44- 5 children already- TTC number 6!
iVillage Member
Registered: 01-27-2009
Fri, 08-20-2010 - 6:55pm
I took EPO for one cycle and got my period way early. Did not like it! It could have messed you up..
-mch
iVillage Member
Registered: 09-13-2007
Fri, 08-20-2010 - 7:03pm
EPO didn't do me any favors either.
 


 


Susan V

iVillage Member
Registered: 11-01-2008
Fri, 08-20-2010 - 8:31pm

I didn't ovulate the month I went to New Zealand for a vacation - travel, stress of travel - all of that. I was totally gearing up to, got a positive OPK and then no temp shift.

EPO never gave me any EWCM either - I just used pre-seed when I needed it.

Georgie

iVillage Member
Registered: 08-19-2010
Fri, 08-20-2010 - 9:54pm

Thanks! I am thinking of trying Pre- Seed or Conceive Well (better reviews) for when I actually start TTC (am doing herbs/acu for 3 months before I even attempt TTC to gear my body up so I don't miscarry etc;).

I did get EWCM from days 11-14 and my cervix was wide open too. I thought a temp shift would take place but it has not. Breasts only slightly sore- not really and not full like they normally get after O.

I spent 3 months in OZ so am thinking the jet lag and time zone change could be a huge factor.

44- 5 children already- TTC number 6!
iVillage Member
Registered: 05-31-2004
Sat, 08-21-2010 - 8:02am
I am really not sure, I have not used EPO for that, just for getting things ready to avoid an induction!

Michelle


Loving Mom to three

Michelle


Loving Mom to three rambunctious